new layout?

Doc

Trust me, I'm The Doctor.
V.I.P.
#4
Do you have AdBlock turned on? It might have blocked the images in the left column by accident.
 

Doc

Trust me, I'm The Doctor.
V.I.P.
#6
In FireFox, if you have it installed, you go to the "Tools" drop down box and click "Adblock Plus Preferences." Under the "Options" drop down menu you can check and uncheck "Enable Adblock Plus."

I have it but I don't use it because it can block some stuff I like.